Akelpad portable install not clean ?

Ask other users about problems encountered with portable apps or help by posting solutions to existing problems.
Post Reply
Message
Author
ninja1
Posts: 7
Joined: Mon Apr 28, 2008 4:51 pm

Akelpad portable install not clean ?

#1 Post by ninja1 » Mon Apr 28, 2008 5:32 pm

I intalled Akelpad per the instructions at portablefreeware.com. Everything works fine. Except...next time I used my computer in non-portable mode, I discovered that some file associations are changed to Akelpad rather than the original Notepad. I have since change everything back.

The install directions say "Download the ZIP package and extract to a folder of your choice". I downloaded the zip file to HD, then used 7zip to extract directly to a folder on the USB stick. Akelpad is a great product and I will likely install in on my HD in future, but this unexpected changing of my file associations settings is not cool.

cmmehl
Posts: 127
Joined: Sun Feb 19, 2006 7:26 am

#2 Post by cmmehl » Mon Apr 28, 2008 8:10 pm

The portability instructions actually mention some more steps:
How to extract: Download the ZIP package and extract to a folder of your choice. Launch AkelPad.exe. Go to the "Settings" dialog from the "Options" menu. Under "General", set "Recent files" and "Search history" to "0". Under "Advanced (1)", set "Save settings" to "INI File".
Have you followed these?

Cheers
Chris

ninja1
Posts: 7
Joined: Mon Apr 28, 2008 4:51 pm

#3 Post by ninja1 » Tue Apr 29, 2008 7:05 am

Thanks Chris for the quick response.

Yes, I followed all of the steps exactly, before opening any file. I quoted only the first step, because that was the only part that I had a small doubt about. Was it a mistake to download the .zip file to HD? My OS is 98SE, btw.

cmmehl
Posts: 127
Joined: Sun Feb 19, 2006 7:26 am

#4 Post by cmmehl » Tue Apr 29, 2008 9:11 am

Strange, here Akelpad doesn't change any file associations.

I actually don't understand what you mean by using a computer in "non-portable mode"? And how did you use Akelpad, i.e. how did you open a file with it?

I'm on XP, however, and maybe it's an issue with Win98 (hard to imagine, though ...).

Good luck
Chris

ninja1
Posts: 7
Joined: Mon Apr 28, 2008 4:51 pm

#5 Post by ninja1 » Tue Apr 29, 2008 11:52 am

OK. On my PC, I've always used Notepad as my text editor. Then I installed AkelPad onto my USB stick, using the steps already discussed. How do I open file? Open AkelPad, then click File-->Open... then browse for the file I want to open, then click the filename, then click the 'Open' button. I tried out AkelPad for a while, viewing existing files, creating new files, and using other portable apps (only AkelPad and Firefox so far). Then, I closed all the portable apps and unplugged the USB stick from my PC. When I say "non-portable mode" that is what I mean: No portable apps running and USB stick is unplugged. Later (with USB stick still unplugged), I needed to open a text file on my PC. I used Windows Explorer or My Computer (can't remember which) to browse for the filename, and (surprise!) noticed the AkelPad icon beside some filetypes (ini,inf,txt,log). When I double click the desired file, I get error about cannot find AkelPad, etc.

User avatar
chadross
Posts: 39
Joined: Fri Jun 29, 2007 6:37 pm
Location: Canada
Contact:

File types setting

#6 Post by chadross » Tue Apr 29, 2008 12:08 pm

By any chance did you inadvertantly check the box next to "Open" on the Advanced(1) Tab in the Settings dialog.

Even if you have save to INI enabled; if you check any of the File types associations AkelPad will associate the specified extensions. An the defaults are "txt;log;ini;inf" for Open.

You will have to manually reassociate these to notepad, but first make sure the Open, Edit and Print options are NOT checked in Akelapd.
Chad

ninja1
Posts: 7
Joined: Mon Apr 28, 2008 4:51 pm

Re: File types setting

#7 Post by ninja1 » Tue Apr 29, 2008 1:49 pm

chadross wrote:By any chance did you inadvertantly check the box next to "Open" on the Advanced(1) Tab in the Settings dialog.

Even if you have save to INI enabled; if you check any of the File types associations AkelPad will associate the specified extensions. An the defaults are "txt;log;ini;inf" for Open.

You will have to manually reassociate these to notepad, but first make sure the Open, Edit and Print options are NOT checked in Akelapd.
I just took a look...and yes, that box IS CHECKED ! I don't remember checking it, but can't be 100% sure. If it were already checked (by default), I would not have cleared it, because the install instructions do not say anything about that box. Is the "Open" checkbox cleared, by default? Perhaps the instructions should be modifed to explicitly say all 3 (open, edit, print) checkboxes should be cleared, rather than rely on the defaults being correct and/or the user being aware of what those settings do.

I have already manually corrected the .ini, .inf, .txt associations back to Notebook. But I haven't figured out how to fix the .log association, as it does not show up in the listing with the others.

User avatar
chadross
Posts: 39
Joined: Fri Jun 29, 2007 6:37 pm
Location: Canada
Contact:

Associate

#8 Post by chadross » Tue Apr 29, 2008 5:32 pm

If I recall correctly you should be able to Shift+Right Click on the .LOG file and see the Open With menu option. Choose "choose program" if necessary and pick your editor. Make sure to check the "Always use the selected..." before clicking ok.

Alternatively, if that doesn't work you can open an windows explorer window and from the menu select Tools>Folder Option. then go to the File Types tab. Find the Log entry from the list; if not their click the New button and associate that way.
Chad

ninja1
Posts: 7
Joined: Mon Apr 28, 2008 4:51 pm

#9 Post by ninja1 » Tue Apr 29, 2008 7:15 pm

All fixed now.
Thanks Chad.

cmmehl
Posts: 127
Joined: Sun Feb 19, 2006 7:26 am

#10 Post by cmmehl » Wed Apr 30, 2008 2:07 am

Glad to hear that a solution was found :-)

(Unrelated - again, I didn't receive notifications on new posts in this thread, altough I had opted for it. Only received it for the first post after mine :-( ).

Greetz
Chris

Post Reply