gaP: great! another Portabilizer

If you are currently developing portable freeware or planning to do so, use this forum to discuss technical implementation, seek out like-minded developers for partnership, or solicit interested users for beta testing.
Message
Author
Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#31 Post by Stibbert » Tue Jan 30, 2018 1:21 am

I'm trying to move a file (a communication driver) from Settings\System32 to Windows\System32

file = %Windows%\System32\lpcapapi.dll :: Settings\System32\lpcapapi.dll

What I obtain is a new folder in MyApp with the name %Windows%...

What is wrong? Thanks

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#32 Post by Stibbert » Tue Jan 30, 2018 1:51 am

I've found the error: %Windir%

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#33 Post by Stibbert » Thu Feb 01, 2018 11:20 am

I have to write a line in registry in this type:

@="\"C:\\Program Files (x86)\\MyApp\\MyApp.exe\" \"%1\""

There are some single quote and double quote.
GAP add a " every time find single quote...
How can avoid this?

IS POSSIBLE???

Thanks

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#34 Post by Stibbert » Thu Feb 01, 2018 11:28 am

Sorry.

I've make a mistake...

The symbol is backslash \

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#35 Post by Stibbert » Mon Feb 19, 2018 1:00 am

GAP is still supported or it is an abandonware?

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#36 Post by Stibbert » Fri Feb 23, 2018 8:53 am

I don't understand...

I have a folder in AppData/Local.
I have written:

dir = %AppData%\Local\MyFolder :: Settings/MyFolder
dir = %AppData%\MyFolder :: Settings/MyFolder

Not in the same app, in two different test, but nothing happen...

If MyFolder was in Appdata/Local wasn't copied to Settings.
If is in Settings, is not copied in AppData/Local.

Other times (other appplications) everythings goes well.

What is wrong?

Thanks

User avatar
Midas
Posts: 4120
Joined: Mon Dec 07, 2009 7:09 am
Location: Sol3

Re: gaP: great! another Portabilizer

#37 Post by Midas » Sat Feb 24, 2018 5:03 am

I may be wrong here, but the first case (line) looks malformed to me -- i.e., the 'Local' segment is usually implicit...

You could try it with yaP...

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#38 Post by Stibbert » Sun Feb 25, 2018 2:34 am

Thanks.

But GAP and YAP Shouldn't have the same syntax?

(I know and I'm sure AppData/Roaming is implicit).

User avatar
Midas
Posts: 4120
Joined: Mon Dec 07, 2009 7:09 am
Location: Sol3

Re: gaP: great! another Portabilizer

#39 Post by Midas » Sun Feb 25, 2018 4:50 am

Sorry, I wouldn't know, I haven't done any significant use of gaP...

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#40 Post by Stibbert » Thu Mar 01, 2018 9:06 am

Good morning.

I've written:

!admin = 1
file = %Windir%\System32 :: Settings/System32/Mylibrary.dll

The goal is move a file from Settings/System32 to Windows/System32 but the code don't work...
Why?

Thanks

User avatar
SYSTEM
Posts: 1758
Joined: Sat Jul 31, 2010 1:19 am
Location: Helsinki, Finland

Re: gaP: great! another Portabilizer

#41 Post by SYSTEM » Thu Mar 01, 2018 9:54 am

Stibbert wrote:
Thu Mar 01, 2018 9:06 am
Good morning.

I've written:

!admin = 1
file = %Windir%\System32 :: Settings/System32/Mylibrary.dll

The goal is move a file from Settings/System32 to Windows/System32 but the code don't work...
Why?

Thanks
My guess: gaP is a 32-bit program, and when it tries to access System32, it gets redirected to SysWOW64.

To work around it, try

Code: Select all

!admin = 1
file = %WinDir%\Sysnative :: Settings/System32/Mylibrary.dll
My YouTube channel | Release date of my 11th playlist: January 26, 2018

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#42 Post by Stibbert » Thu Mar 01, 2018 10:17 am

Don't work! :cry:

The portabilizer create in the main folder (of portabilizer, between App and settings) a folder named %Windows%.

I don'understand...

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#43 Post by Stibbert » Thu Mar 01, 2018 10:23 am

And the same behaviour is if I use SysWOW64!

User avatar
SYSTEM
Posts: 1758
Joined: Sat Jul 31, 2010 1:19 am
Location: Helsinki, Finland

Re: gaP: great! another Portabilizer

#44 Post by SYSTEM » Thu Mar 01, 2018 10:52 am

Stibbert wrote:
Thu Mar 01, 2018 10:17 am
Don't work! :cry:

The portabilizer create in the main folder (of portabilizer, between App and settings) a folder named %Windows%.

I don'understand...
If it's creating a folder named %Windows%, chances are that you wrote %Windows% in the configuration file. It's supposed to be %WinDir% or its newer alternative, %SystemRoot%.
My YouTube channel | Release date of my 11th playlist: January 26, 2018

Stibbert
Posts: 19
Joined: Tue Nov 07, 2017 2:29 am

Re: gaP: great! another Portabilizer

#45 Post by Stibbert » Thu Mar 01, 2018 11:39 am

!chances are that you wrote %Windows% in the configuration file"

Maybe...

I've made many tests to obtain what I was looking for.

(I've tryed GAP and YAP too).

Finaly:

With sysnative, GAP copy the dll to S32, but when closing, the dll remain in windows.

I've a question for you. GAP, after changed icons works again? I've tryed with many computer, but ALWAYS, after icon modified, GAP fail to work!

Post Reply