DropIt

If you are currently developing portable freeware or planning to do so, use this forum to discuss technical implementation, seek out like-minded developers for partnership, or solicit interested users for beta testing.
Message
Author
User avatar
grannyGeek
Posts: 218
Joined: Mon Mar 26, 2007 10:54 pm

Re: DropIt

#391 Post by grannyGeek » Sun Feb 20, 2011 2:29 am

guinness, I know what you mean about RAM usage. Some folks are happily content that their browser or graphics editor uses 250 - 500 mb memory, and screech like a scalded cat over some small tool working hard in the background that exceeds 1 mb.
(I recently tried out Lotus Symphony word processor for snicks & grins --- So Pretty. So slooooowwwwwww. So HUGE! almost 1 GB disk space, and .5 to 1 GB RAM. I saw lots of loving comments about it, and wonder "who ARE these people, and what planet are they from?")

Anyway, the menu icons look wonderful, so you guys' hard work is greatly appreciated.

I'm now downloading test version, and will send Lupo a "QA report" soon.

User avatar
grannyGeek
Posts: 218
Joined: Mon Mar 26, 2007 10:54 pm

Re: DropIt

#392 Post by grannyGeek » Tue Feb 22, 2011 2:57 am

I'm having commandline parameter problems.
From what I can figure out, this stopped working at v 1.2.
Version 1.1.1 does work.

Testing this in XP-Pro, SP3.
I made a small pattern to move text file-type *.txt to a folder.
Made a shortcut icon for DropIt, append to the target line the Profilename and the Path & file-type of the source file.

If I drop the source file onto the icon, there is error message "sorting partially failed", but the file actually does get moved.
If I double-click the shortcut, same error message, and file does NOT move.
Command Prompt and Batch File fail with the same error message.

Can anyone confirm this behavior?

Thanks

User avatar
guinness
Posts: 4118
Joined: Mon Aug 27, 2007 2:00 am
Contact:

Re: DropIt

#393 Post by guinness » Tue Feb 22, 2011 5:12 am

Make sure you have the newest version of Copy.dll & Copy_x64.dll in the Lib/copy folder and use the V1.5 Version.If you are using V1.2 make sure you have those files (see above) that came with that Version, as the DLL structure was changed.

Also maybe try in a Fresh Copy of DropIt V1.2 to see if the problem is there?! Because I can't replicate the problem with my version.
Added 179 Applications: Portable

User avatar
Lupo73
Posts: 1011
Joined: Mon Mar 19, 2007 8:55 am
Location: Italy
Contact:

Re: DropIt

#394 Post by Lupo73 » Tue Feb 22, 2011 6:06 am

grannyGeek, I'm fixing some of the issues you reported me. About the commandline problem, can you verify if it happens also with a single file as parameter or not?
You reported me this example line:
B:\_Project\DropIt_1_6_Test\Dropit.exe –default B:\Source\*.txt
Try this one:
B:\_Project\DropIt_1_6_Test\Dropit.exe –default B:\Source\test.txt

It could help me to exclude some causes..

User avatar
grannyGeek
Posts: 218
Joined: Mon Mar 26, 2007 10:54 pm

Re: DropIt

#395 Post by grannyGeek » Tue Feb 22, 2011 7:02 pm

@ guinness, I downloaded fresh versions of 1.2 and 1.5 from the Soure Forge page.
I still get the same behavior. I've tested this on two XP machines, and on my Vista 64-bit laptop.

@ Lupo
By adding a specific file name --
v1-2, v1-5, and v1.6_20-Feb_build
all work perfectly with drop onto shortcut icon or with double-click or with Batch File/Command Prompt.

Hah --- a clue?
If I'm using wildcard instead of specific filename, and other txt files already exist in destination folder, I get "Item Already Exists" msgbox. I choose Yes to overwrite, then get the msgbox "Sorting Failed for *.txt"


The flickering profiles list ----
In Vista, the dialog only flickers as I move the hovered cursor in and out of the dialog.
In XP, the flicker of the dialog is always there, but it is not a steady on-off flicker, it is more like a sporadic flash between the dialog flashing as black, back to normal, then the dropdown list window flashes as black, back to normal, etc. It is very fast flicker occurring in fractions of a second.
Clicking on the dialog itself has no effect, but when I click to display the dropdown list, the list appears normal while the dialog behind it continues to flicker.
Do you have some sort of GUI activation or update going on there?

User avatar
Lupo73
Posts: 1011
Joined: Mon Mar 19, 2007 8:55 am
Location: Italy
Contact:

Re: DropIt

#396 Post by Lupo73 » Wed Feb 23, 2011 1:08 am

I may have found a solution also for it. Check your email, a new test version is ready for you :)

An extra note: grannyGeek reported me a possible feature I previously disabled (and now restored), the ability to send also folders to associated programs using Open With. So in final release you will be able also to create folder-patterns with Open With processing mode, useful for example to open them with file managers like FreeCommander. :wink:

User avatar
Lupo73
Posts: 1011
Joined: Mon Mar 19, 2007 8:55 am
Location: Italy
Contact:

Re: DropIt

#397 Post by Lupo73 » Wed Feb 23, 2011 2:42 am

I have decided to publish a Release Candidate version, to allow all users to test it. This new update is simply a more stable version, with some fixes and cosmetic changes.
I finally decided that also Processing Mode was not very efficient and replaced it with a simple "Action" (I hope you like this choice, I think it gives a better and easier idea of what it is).
Now there are only minor fixes and the Help update to do, than the final release will be available. Here the link to download this pre-release:
http://www.lupopensuite.com/files/dropi ... rtable.zip
http://www.lupopensuite.com/files/dropi ... Source.zip

Language update:

Code: Select all

ADDED:
MANAGE_ACTION=Action
MANAGE_DESTINATION_PROGRAM_SELECT=Select a destination program:
MANAGE_DESTINATION_PROGRAM=Destination Program
MANAGE_EDIT_MSGBOX_10=Executable
OPEN_WITH=Open With
OPTIONS_TAB_3=Various
POSITIONPROCESS_LOG_7=Opened With

MODIFIED:
MANAGE_EDIT_MSGBOX_0=Destination Error
MANAGE_EDIT_MSGBOX_1=You must specify a valid destination.
MANAGE_EDIT_MSGBOX_8=Action
MANAGE_EDIT_TIP_2=As destination are supported both absolute and relative paths.
MOREMATCHES_LABEL_0=Loaded item:
OPTIONS_CHECKBOX_11=Show Sorting Progress Bar during process

REMOVED:
MANAGE_TRANSFER_MODE=Transfer Mode
Last edited by Lupo73 on Wed Feb 23, 2011 3:12 am, edited 1 time in total.

User avatar
guinness
Posts: 4118
Joined: Mon Aug 27, 2007 2:00 am
Contact:

Re: DropIt

#398 Post by guinness » Wed Feb 23, 2011 2:58 am

When I was testing grannyGeek I wasn't using wildcards this is why I didn't get a problem in the Commandline! But I confirm that there was a problem e.g. C:\Program Files\DropIt\DropIt.exe -Default C:\Files\*.txt but now this has been Fixed by Lupo73, because I was busy yesterday to check it! :(

Also I am unable to replicate the in Flicker in "Customize Profiles" with Windows 7 and XP.
Added 179 Applications: Portable

User avatar
tproli
Posts: 1172
Joined: Sat Sep 09, 2006 10:14 am
Location: Hungary
Contact:

Re: DropIt

#399 Post by tproli » Wed Feb 23, 2011 4:13 am

Yes, Action sounds better then Processing Mode.

Here's the newest Hungarian language file:
http://dl.dropbox.com/u/17407690/DropIt ... _v1.6b.lng

User avatar
grannyGeek
Posts: 218
Joined: Mon Mar 26, 2007 10:54 pm

Re: DropIt

#400 Post by grannyGeek » Wed Feb 23, 2011 4:41 am

Ok, I just had successful test run of commandline parameters with the build of 23-Feb, so hooray!
Looks like the RC is solid.

EDIT ADDED:
@guinness, I'm sorry, I wasn't clear enough in my intial report.
When I drop files on the exe, the little dialog that pops up with the profiles list to choose from, it flickers like a strobe.
Try dropping some files on your exe, and see how the popup looks for you.
In vista, I only get a little flicker when I move the cursor over the dialog, but in XP it is very severe.


Tested on three machines now. I tried it from a different portable drive, and tried it from the hard-drive. But it functions ok. I'll fiddle around some more with different profile settings and such, see if I can find a clue.

Good night guys, it has been a very long day.

User avatar
guinness
Posts: 4118
Joined: Mon Aug 27, 2007 2:00 am
Contact:

Re: DropIt

#401 Post by guinness » Wed Feb 23, 2011 11:18 am

@guinness, I'm sorry, I wasn't clear enough in my intial report.
When I drop files on the exe, the little dialog that pops up with the profiles list to choose from, it flickers like a strobe.
Try dropping some files on your exe, and see how the popup looks for you.
In vista, I only get a little flicker when I move the cursor over the dialog, but in XP it is very severe.
FIXED! I see now what you meant. On Windows 7 this wasn't the case also with all the coding one thing can break another :) I tested on XP SP3 without any problem.

Plus, I just sent a new update to Lupo73 with Profile Folder Encryption.
Added 179 Applications: Portable

User avatar
grannyGeek
Posts: 218
Joined: Mon Mar 26, 2007 10:54 pm

Re: DropIt

#402 Post by grannyGeek » Wed Feb 23, 2011 4:08 pm

Snellfrocky! Dirty fingernails! Spit!!!

A bug. (twin bugs)
/\o/\ /\o/\
Two msgboxes never appear, and DropIt waits for them indefinitely, using 50% CPU, and has to be killed with Task manager.

The "File Already Exists" msgbox for duplicate items, and the "Destination Folder Problem" msgbox if the folder can't be created.

Every time you fix one spot, something else gets affected. I hope this is an easy fix for you.

User avatar
Lupo73
Posts: 1011
Joined: Mon Mar 19, 2007 8:55 am
Location: Italy
Contact:

Re: DropIt

#403 Post by Lupo73 » Thu Feb 24, 2011 12:07 am

I think these new bugs are caused by an updated library used for MsgBox (ExtMsgBox).
The previous freezing problem of too long patterns was not a DropIt problem, but a problem of ExtMsgBox itself (that doesn't support long strings).

User avatar
grannyGeek
Posts: 218
Joined: Mon Mar 26, 2007 10:54 pm

Re: DropIt

#404 Post by grannyGeek » Thu Feb 24, 2011 12:27 am

Is there a fix or workaround?

My paths and pattern strings were very short when I got these new behaviors....

User avatar
Lupo73
Posts: 1011
Joined: Mon Mar 19, 2007 8:55 am
Location: Italy
Contact:

Re: DropIt

#405 Post by Lupo73 » Thu Feb 24, 2011 1:54 am

I sent you an update that may fix the problem.. verify it and make your report ;)

Post Reply