WinPenPack's X-Launcher updated

If you are currently developing portable freeware or planning to do so, use this forum to discuss technical implementation, seek out like-minded developers for partnership, or solicit interested users for beta testing.
Message
Author
User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher update

#61 Post by rbon »

sl23 wrote: Thu Jun 06, 2024 11:44 am So I downloaded the sc550 executable, which does recognise AU3 files.
This file/archive is wrong for Your Windows.

You must download the correct SciTE archive and go to:
1. Sourceforge.net -- > SciTE releases https://sourceforge.net/projects/scintilla/files/SciTE/
2. select rel. 5.5.0
3. download one of two files taht name begin with 'w' (Windows) like:
- wscite32_550.zip ; this is 32 bit SciTE for Windows
- wscite550.zip ; this is 64 bit SciTE for Windows
download the file https://sourceforge.net/projects/scinti ... p/download

With WinRAR (or similar program) open wscite550.zip --> open the folder 'wscite' and extract all files (there are only files, no directories) inside Your folder:
for example:
--> 'C:\PortableApps\X-SciTE4AutoIt3\Bin\AutoIt\3.3.16.1\SciTe\'
4. open Your SciTE and press Help --> About SciTE

You must see a dialog box with these infos:
SciTE
Version 5.5.0 Scintilla:5.5.0 Lexilla:5.3.2
Apr 23 2024 15:42:36
by Neil Hodgson.
December 1998-April 2024.
http://www.scintilla.org
Lua scripting language by TeCGraf, PUC-Rio
http://www.lua.org
Contributors:
name a
name b
and other names
this means that You have 64 bit version of SciTE.
If you had a 32 bit version you would find written in the help file:
--> Scite 5.5.0 - 32 bit
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher updated

#62 Post by rbon »

sl23 wrote: Sat Jun 08, 2024 6:27 am Following Argumentum's advice on the AutoIT forum, I recompiled X-Launcher using AutoIT v3.2.12.1 to a 64bit EXE. Compiling from SciTE only gives a 32bit EXE. But if you open Aut2Exe, it works, and guess what?
It fixes the SplashScreen not showing!!!! Woohoo!!!!
X-Launcher_x64 v1.5.4.zip
Adjusted command to compile as x64.
Set Language to 2057 English.
Great, I'm happy for you.

If I understood correctly:
1. there are no errors in the x-launcher 1.5.4 sources
2. you need to use an old version of AutoIt (3.2.12.1)
3. you need to go to the '\Aut2Exe' folder
4. you need to launch the executable 'Aut2exe_x64.exe'
it's correct ?

I read somewhere the difference between using:
- X-SciTE with syntax checking
- or use the 'Aut2exe_x64.exe' compiler directly

The compiler does NOT perform the syntax check, but only checks whether the file_name indicated in the .au3 file actually corresponds to the file_name you want to obtain --> see viewtopic.php?p=107049#p107049

This means that if there are errors in the source code they are ignored by the compiler 'Aut2exe_x64.exe' (also with 32 bit version) and, in principle, your x-launcher.exe may contain errors that will only be seen with its practical use.
Unfortunately there are no shortcuts in programming.

I still have a doubt.
X-SciTE doesn't compile at 64 bit because depends on the editor version?
That is, you could try the configuration
- in 'C:\PortableApps\X-SciTE4AutoIt3\Bin\AutoIt\' create the folder '3.2.12.1'
- in X-SciTE4AutoIt3.ini modify line 33 - AppVer and indicate 3.2.12.1
(AppVer behaves like a pointer to a specific folder)
- SciTE 5.5.0 - 64 bit (see previous post) must be copied to the 3.2.12.1 folder.
- try to compile as 64 bit

I don't know if all this is worth it.
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

User avatar
sl23
Posts: 84
Joined: Fri Jan 02, 2015 6:25 am

Re: WinPenPack's X-Launcher updated

#63 Post by sl23 »

Thanks rbon, but that's what I did in the first place. It doesn't recognise AU3 files, but the sc550 version did. I'll have to ask on AutoIT forum. :)
Latest X-Launcher_x64 update - Compiled with Aut2exe_x64.exe v3.3.16.1
Latest X-Launcher_x64 v1.5.4 update - Compiled with Aut2exe_x64.exe v3.2.12.1

User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher updated

#64 Post by rbon »

sl23 wrote: Sat Jun 08, 2024 12:05 pm Thanks rbon, but that's what I did in the first place. It doesn't recognise AU3 files, but the sc550 version did. I'll have to ask on AutoIT forum. :)
Strange, very strange. I'll try to investigate.

I have also opened X-SciTE --> Language --> select 'AutoIt3'. In this way You select a specific lexer (syntax highlighting for AutoIt3)

But I don't really interested to You version of SciTE. As long as it works.
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

User avatar
sl23
Posts: 84
Joined: Fri Jan 02, 2015 6:25 am

Re: WinPenPack's X-Launcher updated

#65 Post by sl23 »

rbon wrote: Sat Jun 08, 2024 12:02 pm If I understood correctly:
1. there are no errors in the x-launcher 1.5.4 sources
2. you need to use an old version of AutoIt (3.2.12.1)
3. you need to go to the '\Aut2Exe' folder
4. you need to launch the executable 'Aut2exe_x64.exe'
it's correct ?
Yes all correct except number 1. There are still errors appearing even with this version of AutoIT.

Handy to know the differences. ;)

I have already installed v3.2.12.1 by copying the original X-SciTE.ini and X-SciTe launcher. Exactly how you suggested.

As you say, only through use will errors appear. I may have found one already!
I am using this INI code for IObit DriverBooster:
Spoiler!   

Code: Select all

[Setup]
AppName=DriverBooster

[FileSystem]
Root=@ScriptDir@
Bin=.\Bin
Lib=.\Lib
Backup=.\Backups

[FileToRun]
PathToExe=$Bin$\$AppName$\$AppName$.exe

[Options]
DeleteTemp=true
MultipleIstances=false
FixAppData=true
RunWait=true
ShowSplash=true
WriteLog=false

[SplashScreen]
Image=$Lib$\Graphics\x-splash.jpg
;Title=$AppName$
TimeOut=1500

[Environment]
USERPROFILE=$Lib$\
LOCALAPPDATA=$Lib$\
PROGAMFILES(x86)=$Lib$\
PROGRAMDATA=$Lib$\

[RunBefore]
;DirCopy: Option '|o' for overwriting existing files.
DirCopy=$Lib$\AppData|C:\Users\%USERNAME%\AppData|o
DirCopy=$Lib$\Program Files (x86)|C:\|o
DirCopy=$Lib$\ProgramData|C:\|o

[RunAfter]
;Move: Option '|o' overwrites all files and folders, the source folder is deleted. 
;Remove: Option '|e' for deleting only empty directories, recursively.
DirRemove=$Lib$\Microsoft|
DirRemove=C:\ProgramData\iTop|
DirRemove=$Lib$\|e
DirMove=C:\Users\%USERNAME%\AppData\LocalLow\IObit|$Lib$\AppData\LocalLow\|o
DirMove=C:\Users\%USERNAME%\AppData\Roaming\IObit|$Lib$\AppData\Roaming\|o
DirMove=C:\Program Files (x86)\Common Files\IObit|$Lib$\Program Files (x86)\Common Files\|o
DirMove=C:\ProgramData\IObit|$Lib$\ProgramData\|o
Although it moves folders ok, it seems to intermittently have a problem deleting some of them with this code:

Code: Select all

DirRemove=$Lib$\Microsoft|
DirRemove=$Lib$\|e
I suspect it is the reference to the $Lib$ Variable? But it has no problems with using the Lib folder in usage. So not sure what that is. Perhaps it's just code relating to both Lib folder and deleting folders?

This DirRemove=$Lib$\|e seems to work ok, but the other on - DirRemove=$Lib$\Microsoft| just doesn't want to work for some reason.
Last edited by sl23 on Sat Jun 08, 2024 12:33 pm, edited 2 times in total.
Latest X-Launcher_x64 update - Compiled with Aut2exe_x64.exe v3.3.16.1
Latest X-Launcher_x64 v1.5.4 update - Compiled with Aut2exe_x64.exe v3.2.12.1

User avatar
sl23
Posts: 84
Joined: Fri Jan 02, 2015 6:25 am

Re: WinPenPack's X-Launcher updated

#66 Post by sl23 »

rbon wrote: Sat Jun 08, 2024 12:18 pm
sl23 wrote: Sat Jun 08, 2024 12:05 pm Thanks rbon, but that's what I did in the first place. It doesn't recognise AU3 files, but the sc550 version did. I'll have to ask on AutoIT forum. :)
Strange, very strange. I'll try to investigate.

I have also opened X-SciTE --> Language --> select 'AutoIt3'. In this way You select a specific lexer (syntax highlighting for AutoIt3)

But I don't really interested to You version of SciTE. As long as it works.
Tbh, I think I've probably messed up v3.3.16.1 by adding different versions beta updates and stuff! I did create a backup first though ;)
Latest X-Launcher_x64 update - Compiled with Aut2exe_x64.exe v3.3.16.1
Latest X-Launcher_x64 v1.5.4 update - Compiled with Aut2exe_x64.exe v3.2.12.1

User avatar
sl23
Posts: 84
Joined: Fri Jan 02, 2015 6:25 am

Re: WinPenPack's X-Launcher updated

#67 Post by sl23 »

Do you use the AutoRunLWMenu at all? I'm having great troubles getting things to work in that, don't know if it's me or the app? lol
Latest X-Launcher_x64 update - Compiled with Aut2exe_x64.exe v3.3.16.1
Latest X-Launcher_x64 v1.5.4 update - Compiled with Aut2exe_x64.exe v3.2.12.1

User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher updated

#68 Post by rbon »

sl23 wrote: Sat Jun 08, 2024 12:28 pm
rbon wrote: Sat Jun 08, 2024 12:02 pm
If I understood correctly:
1. there are no errors in the x-launcher 1.5.4 sources
2. you need to use an old version of AutoIt (3.2.12.1)
3. you need to go to the '\Aut2Exe' folder
4. you need to launch the executable 'Aut2exe_x64.exe'
it's correct ?
Yes all correct except number 1. There are still errors appearing even with this version of AutoIT.
I did an experiment:
I have added in AutoIt3 ver. 3.2.12.1 the subfolder 'SciTE' with SciTE ver. 1.7.7.0 including AutoIt3Wrapper and I compiled X-Launcher_x64.exe without errors and with the details visible in the Properties -> Details screen and language changed from 2057 (British english) to 1040 (Italian - default).

Remember:
1. in 'AutoIt3/Aut2Exe' dialog box I had already selected compilation x64 and file_name
2. in the 'Resource Update' (AutoIt3Wrapper GUI) dialog box You must change language
3. You can easily find Language Codes at https://wiki.freepascal.org/Language_Codes --> see third column LCID Decimal (language code of English - United States is 1033)

If you are interested You can find here at bottom the X-SciTE4AutoIt3 package containing (both versions):
1. X-SciTE with AutoIt 3.2.12.1 and SciTE 1.7.7.0 32-bit
2. X-SciTE with AutoIt 3.3.16.1 and SciTE 5.5.0 64-bit

MediaFire
X-SciTE4AutoIt3_5.5.0_x64_rev6.zip https://www.mediafire.com/file/25k3zc8i ... 6.zip/file

Here You can see SciTE 1.7.7.0 at work with AutoIt3Wrapper GUI on AutoIt3 rel. 3.2.12.1:

Image
Last edited by rbon on Thu Jun 13, 2024 6:56 am, edited 1 time in total.
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher updated

#69 Post by rbon »

Here is my version of x-launcher 1.5.4 - 64 bit, compiled with the instructions indicated in my previous post. viewtopic.php?p=107143#p107143

MediaFire
X-Launcher_1.5.4_x64_launcher+sources.zip: https://www.mediafire.com/file/2a13wgof ... s.zip/file
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

User avatar
sl23
Posts: 84
Joined: Fri Jan 02, 2015 6:25 am

Re: WinPenPack's X-Launcher updated

#70 Post by sl23 »

Much appreciated rbon! Will take a look when I get time. Thanks so much for your help with this :)
Latest X-Launcher_x64 update - Compiled with Aut2exe_x64.exe v3.3.16.1
Latest X-Launcher_x64 v1.5.4 update - Compiled with Aut2exe_x64.exe v3.2.12.1

User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher updated

#71 Post by rbon »

X-Launcher 1.5.4 - x64 compiled with AutoIt3 ver. 3.3.16.1.

I tried to compile X-Launcher with AutoIt3 ver 3.3.16.1, but it didn't compile and I got the following errors:

Code: Select all

+>         SciTEDir => C:\PortableApps\X-SciTE4AutoIt3\Bin\AutoIt\3.3.16.1\SciTe   UserDir => C:\PortableApps\X-SciTE4AutoIt3\Bin\AutoIt\3.3.16.1\SciTE\AutoIt3Wrapper   SCITE_HOME => C:\PortableApps\X-SciTE4AutoIt3\Bin\AutoIt\3.3.16.1\SciTE 
-> No changes made..
>Running AU3Check (3.3.16.1)  from:C:\PortableApps\X-SciTE4AutoIt3\Bin\AutoIt\3.3.16.1  input:C:\downloads\wPP launchers\X-Launcher64\X-Launcher\x-compiler.au3
"C:\downloads\wPP launchers\X-Launcher64\_x-launcher\x-udf.au3"(938,22) : error: undefined macro.
	While @InetGetActive
	~~~~~~~~~~~~~~~~~~~~^
"C:\downloads\wPP launchers\X-Launcher64\_x-launcher\x-udf.au3"(939,37) : error: undefined macro.
		$iCount = Round(@InetGetBytesRead /
		~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
"C:\downloads\wPP launchers\X-Launcher64\_x-launcher\x-udf.au3"(943,23) : error: undefined macro.
	If @InetGetBytesRead =
	~~~~~~~~~~~~~~~~~~~~~^
"C:\downloads\wPP launchers\X-Launcher64\_x-launcher\x-udf.au3"(944,23) : error: undefined macro.
	If @InetGetBytesRead <>
	~~~~~~~~~~~~~~~~~~~~~^
"C:\downloads\wPP launchers\X-Launcher64\_x-launcher\x-udf.au3"(1242,35) : error: AdlibEnable(): undefined function.
	AdlibEnable("_TrayTipOff", $time)
	~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
"C:\downloads\wPP launchers\X-Launcher64\_x-launcher\x-udf.au3"(1255,16) : error: AdlibDisable(): undefined function.
	AdlibDisable()
	~~~~~~~~~~~~~~^
C:\downloads\wPP launchers\X-Launcher64\X-Launcher\x-compiler.au3 - 6 error(s), 0 warning(s)
!>17:53:44 AU3Check ended. Press F4 to jump to next error.rc:2
+>17:53:44 AutoIt3Wrapper Finished.
>Exit code: 2    Time: 9.775
I thought the errors were actually due to obsolete (deprecated) functions that were eliminated with AutoIt3 versions after rel. 3.2.12.1.

I looked on the AutoIt website https://www.autoitscript.com/autoit3/docs/functions.htm to see if the functions reported as errors were still present: no, these functions were eliminated because they were deprecated.

Here is a tiny memo about functions deprecated:

Code: Select all

Deprecated AutoIt3 rel. 3.3.16.1 functions

                                          AutoIt3           AutoIt3
file                                      3.2.12.1          3.3.16.1
----------------------------------------------------------------------------------------------------------
\_x-launcher\x-udf.au3            InetGetBytesRead       InetGetInfo
\_x-launcher\x-udf.au3            AdlibEnable            AdLibRegister
\_x-launcher\x-udf.au3            AdlibDisable           AdlibUnRegister
\_x-launcher\x-launcher.au3       ;User Preferences\;Options   --> decommented '$ShowSplash' (removed ';--')
\_x-launcher\x-launcher.au3       ;User Preferences\;Options   --> decommented '$ShowTrayTip' (removed ';--')
\_x-launcher\x-launcher.au3       _SplashScreen          _SplashImageOn
Well, the compilation runs smoothly and is produced an executable with name 'X-Launcher_x64.exe'.
I thought, after the changes, to name X-Launcher 1.5.5 - x64.

Tested with X-LibreOffice x64 and runs regularly, but do not display Splash Screen: edited X-LibreOffice.ini and changed value in section [Options] --> 'ShowSplash=true'.
I think that the solution about Splash Screens not showed should not be far away yet.

That's all for now.

For the brave ones who want to do some experiments here is the latest build.

MediaFire:
X-Launcher_1.5.5_x64_launcher+sources.zip: https://www.mediafire.com/file/f0hlbhju ... s.zip/file
Last edited by rbon on Tue Jun 18, 2024 8:43 am, edited 1 time in total.
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

User avatar
sl23
Posts: 84
Joined: Fri Jan 02, 2015 6:25 am

Re: WinPenPack's X-Launcher updated

#72 Post by sl23 »

Excellent work, thanks for checking that, clearly you know more than me! ;)
Latest X-Launcher_x64 update - Compiled with Aut2exe_x64.exe v3.3.16.1
Latest X-Launcher_x64 v1.5.4 update - Compiled with Aut2exe_x64.exe v3.2.12.1

User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher updated

#73 Post by rbon »

I reviewed the suggestion stated in the memo see post viewtopic.php?p=107165#p107165:
"Deprecated AutoIt3 rel. 3.3.16.1 functions"

Code: Select all

\_x-launcher\x-launcher.au3       ;User Preferences\;Options   --> decommented '$ShowSplash' (removed ';--')
\_x-launcher\x-launcher.au3       ;User Preferences\;Options   --> decommented '$ShowTrayTip' (removed ';--')
This suggestion is wrong because the check on SplashScreen is performed 2 (twice) times (Global Preferences and User Preferences) (see at line 280 of x-launcher.au3). So I have commented ii again in User Preferences.
In conclusion if You use only one SplashScreen check, launcher is much faster.
(and I have arready updated my upload on MediaFire)

SpashScreen and why is not works on x-launcher 1.5.5 x64.
The reason for the failure is due to the fact that the SplashScreen function has been deprecated in AutoIt3 rel. 3.3.16.1 and it has now been replaced by 2 (two) new functions:
1. SplashImageOn --> shows images only (as x-splash.jpg)
2. SplashTextOn --> shows text only
(and You must use SplashOff for turns SplashImage or SplashText off).

SplashImageOn requires the x-launcher to look on disk for the image to display which is therefore no longer incorporated into the x-launcher itself (as in AutoIt3 rel. 3.2.12.1).
(this behavior was present in AutoIt2)
see Functions --> SplashImageOn https://www.autoitscript.com/autoit3/do ... mageOn.htm --> example:
Local $sDestination = "..\GUI\mslogo.jpg"
this means that the x-splash.jpg file is really an external file, not incorporated into the launcher and which must be searched and showed for by the launcher itself when the portable program is started.
In conclusion it is necessary to completely rewrite the 'SplashScreen' routine (from line 453 of the x-launcher.au3 file) so that it searches for the 'x-splash.jpg' file on disk.

For example You can insert in Splashschreen routine this instruction:
'Local $sDestination = ".\Bin\$AppName$\x-splash.jpg" or, simply
;Local $sDestination = ".\x-splash.jpg"

and then call it back with
SplashImageOn("Splash Screen", $sDestination, 250, 50)
Sleep(3000)
SplashOff()
(this example was taken from the AutoIt3 site and is incorrect because the "Sleep(3000)" and "SplashOff" instructions must be inserted in another location of the file x-launcher.au3)

As soon as I have some time I will try to rewrite the new SplashScreen routine.
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

User avatar
rbon
Posts: 399
Joined: Wed Mar 28, 2007 2:16 am
Location: Italy

Re: WinPenPack's X-Launcher updated

#74 Post by rbon »

rbon wrote: Thu Jun 20, 2024 10:48 am As soon as I have some time I will try to rewrite the new SplashScreen routine.
In small steps...

Here You have a new version of X-Launcher v1.5.5 x64 ver2 with working Splash Screen.

How does it works?
1. examine your x-splash.jpg file: width and height of your splash image and do not accept default values (500 and 400 px = image really too big).
--> for x-splash.jpg (contained in x-launcher sources) these values are: width=307 pixels and height=143 pixels (right-clickon image_file --> Properties --> Details --> Image details)
2. fill the section SplashScreen --> row nr. 453 of file '_x-launcher\x-launcher.au3'
3. determine where you want the launcher to look for the image file (now in \Bin\AppName)
4. determines how long you want show the Splash Screen (file x-splash.jpg) to appear before the program starts (now 3000 milliseconds = 3 seconds)
5. edit Your INI file (i.e. x-launcher_x64.ini) and change value in section [Options] --> 'ShowSplash=true'
6. the launcher does NOT check that the x-splash.jpg is present in the system.

Feedback on this new version is very welcome.

Remember: I only looked at Splash Screen and not TraySetIcon (the new name of the TrayTip function): this function does not works and must be rewritten from scratch.
In other words, the x-launcher icon does not appears in the system tray.

MediaFire
X-Launcher_1.5.5_x64_launcher+sources_v2.zip : https://www.mediafire.com/file/pi5an04q ... 2.zip/file
"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning." - Rick Cook.

Post Reply