Page 1 of 3


Posted: Sat Aug 28, 2010 5:58 am
by joby_toss
PeStudio shows details about applications (*.exe, *.dll, *.cpl, ocx, *.ax, *.sys, ...) without starting them.

Another way to determine if an application is 64bit capable, or to see its dependencies, if it requires .Net and what version etc.


Re: PeStudio

Posted: Sat Aug 28, 2010 8:01 am
by -.-
i like it, seems to work well. no more needing to use sandboxie :D

Re: PeStudio

Posted: Sat Aug 28, 2010 10:28 am
by joby_toss
Sorry guys!
And thank you, Lyx!

Here are the dependencies for PeStudio:

Download here: ... laylang=en

Re: PeStudio

Posted: Sat Aug 28, 2010 1:38 pm
by -.-
odd, my window looks nothing like that lol
wonder if im using an old one or if its just xp... but i dont have those same tabs

Re: PeStudio

Posted: Sun Aug 29, 2010 1:44 am
by joby_toss
That screenshot is not from PeStudio! Although it is capable to scan itself!
It is from UniversalViewer with FileInfo plug-in.

P.S. they added the necessary info about dependencies on their website so they are cool guys and I thank them for that! Nice!

Re: PeStudio

Posted: Sun Aug 29, 2010 2:51 am
by m^(2)
The links to MSVCP90.DLL is
which is certainly wrong.

Re: PeStudio

Posted: Sun Aug 29, 2010 4:35 am
by joby_toss
I noticed the links are wrong but only Andrew can change them.

Re: PeStudio

Posted: Mon Aug 30, 2010 9:47 am
by joby_toss
Version 3.15 looks clean to me now:

I won't push any updates now on this, as 3 is enough in this short time period.

Re: PeStudio

Posted: Mon Aug 30, 2010 11:09 pm
by Andrew Lee
The links to MSVCP90.DLL is
which is certainly wrong.
Thanks for reporting this. I have fixed the code responsible for it.

Re: PeStudio

Posted: Mon Sep 27, 2010 9:42 am
by webfork
> PeStudio

Doesn't seem to be a program for casual users. There's a lot of internal Windows information I don't recognize and not much in the way of documentation or help. Is anyone using this to test portability?

Re: PeStudio

Posted: Tue Dec 06, 2011 5:16 am
by joby_toss
I am still using UE/File info plugin combo for that testing part of the process and the main reason for that is 'cause I managed to get a working FreeCommander toolbar button for it. I select my tested .exe and hit that button...bum...instant info! :)

Can't do the same currently with PeStudio. I don't know if there is no command line support for file opening string or if something else than ""%ActivSelAsFile%"" parameter must be used for this to work in FC.

It definitely needs a help file.

Edit: mailed them about command line switches. Let's see now...

Later edit: good news, command line support is planned for one of the next versions!

Edit 2011.12.06: bumped by mistake, sorry about that!

PeStudio fails consistently

Posted: Mon Apr 08, 2013 12:43 am
by Ascend4nt
This is the only program I've run on my O/S (Win 7 x64) that's consistently failed to work. And I've tried like 10 different versions! I also tried different VC++ 2008 runtimes, but it didn't help. I figure there's got to be more people other than me experiencing this problem?! anyway, here's what I get:

Double-clicking the executable I get this:
Running from the command prompt, I get this:
I wound up cleaning all VC++ 2008 runtimes and loaded up the newest (at ... x?id=26368), v9.0.30729.6161. still no luck.

What's interesting to me is that there must be some dynamic loading of the DLL going on, as the msvcr90.dll doesn't appear in the Imports section for either PEStudio.exe or peparser.dll, yet it gets loaded nonetheless (I'm checking this all with my 'ProcessFunctions' and 'FileImportExports' programs).

I would suggest the author statically link the program to the C++ runtimes, although at first glance it would appear he already does... :?

Re: PeStudio

Posted: Mon Apr 08, 2013 4:08 am
by joby_toss
I never got this error and I'm also using win7x64.
Try contacting the developer directly, he's very friendly. :)
The e.m.a.i.l. address is at the very bottom of this page:

Re: PeStudio

Posted: Wed Apr 10, 2013 1:49 am
by marc ochsenmeier
thanks for the compliment! :-)

Really sorry about this failure.

Actually, I never got this failure. :-(
I always test PeStudio on Windows 7 x64.
Yes, PeStudio is statically linked to msvcr90.

Thanks for your interest in PeStudio! :-)

Yes, help file is missing. I am thinking about it.
The interface file (PeParser.h) is now part of the ZIP package.

Please continue to sent comments!

Don't hesitate to follow PeStudio on Twitter:

Re: PeStudio

Posted: Wed Apr 10, 2013 6:51 pm
by Ascend4nt
joby_toss wrote:Try contacting the developer directly, he's very friendly. :)
Thanks, I missed that email at first. I'll await his response

*edit: hmm, odd - marc ochsenmeier's comment didn't show up when I posted this, but the timestamp says differently? Maybe the post had to be moderator-approved since it was his 1st? Anyway, I'm following up with him via email