Van Loo Software: SSuite, Fandango, OmegaOffice, Ex-Lex, Accel, etc.

Submit portable freeware that you find here. It helps if you include information like description, extraction instruction, Unicode support, whether it writes to the registry, and so on.
Message
Author
donald
Posts: 562
Joined: Wed Dec 19, 2007 4:14 am
Location: knoxville TN USA

Van Loo Software: SSuite, Fandango, OmegaOffice, Ex-Lex, Accel, etc.

#1 Post by donald » Tue Dec 30, 2008 1:31 pm

[Moderator note: this thread is a catch-all for the various programs and frequent rebrandings coming from Van Loo Software (primarily SSuite)]

---

SSuite Office Software found at http://www.ssuitesoft.com/

lists a lot of freeware office suites/utilities

and has an important announcement on the homepage
New Software Developments and Releases.

* Due to popular demand from our software users and public feedback, we have decided to accept the challenge to create a portable office suite.

- It has been given the following name: SSuite Office - BladeRunner { Download Size - 13 MB }

- So watch out for the release of the new portable office suite in early January 2009!
and as you will see on the website
No Java, No dotNet
so while it is to early to submit or test this I want to try it (BladeRunner) as soon as it comes out and I am sure I am not alone

User avatar
nickoftime
Posts: 52
Joined: Sat Dec 22, 2007 11:46 am
Location: USA

#2 Post by nickoftime » Tue Dec 30, 2008 6:19 pm

Count me in... from what I see on their website, Blade Runner sounds promising. In the meantime, I'll continue to mess around with The 5th Element - this suite is packed with some pretty cool stuff.

User avatar
joby_toss
Posts: 2902
Joined: Sat Feb 09, 2008 9:57 am
Location: Romania
Contact:

#3 Post by joby_toss » Tue Dec 30, 2008 9:24 pm

Thanks for mentioning this app!
I am trying to make a JPE launcher for it but i'm having some troubles.

What i wonted to ask you: did you guys check this app for portability?
I don't see any registry entries, no settings written outside the application's folder ...
What i did was to install it with SandBoxie and then moved all the contents of "sandbox\system32" and "sandbox\installation directory" to the same folder.
The problem is that some files need to be registered to the system and i don't know how to deal with this issue.

The taskbar looks nice though and the features also!

Help please! :)

donald
Posts: 562
Joined: Wed Dec 19, 2007 4:14 am
Location: knoxville TN USA

where did you download it

#4 Post by donald » Wed Dec 31, 2008 4:39 am

Where did you download it from? The page for SSuite Office - BladeRunner is http://www.ssuitesoft.com/ssuiteportable.htm

The only active link I can find is a screen shot http://www.ssuitesoft.com/Graphics/BladeRunnerAp.png

If you found the BladeRunner edition please point me to it.

As you will find in the first post I quoted the homepage which says it will be released in early January but today it is still December today.
So watch out for the release of the new portable office suite in early January 2009!
I hope to test the release before I go back to school this January but they could wait till near the end of January.

I just mentioned it to give a heads up to all the active testers out there and anyone else interested.

User avatar
joby_toss
Posts: 2902
Joined: Sat Feb 09, 2008 9:57 am
Location: Romania
Contact:

#5 Post by joby_toss » Wed Dec 31, 2008 6:01 am

So sorry for the misunderstanding ... i was talking about the whole suite, The Fifth Element, this is what i'm trying to run in a portable way now! (The topic's title is "ssoffice" so i didn't think extra :( .)
I'm interested too in BladeRunner version (of course i don't have it yet) but until then i thought i can play with JauntePE some more :) .

Island Boy
Posts: 123
Joined: Wed Sep 19, 2007 7:56 pm

SSuite Office Portable v1.0

#6 Post by Island Boy » Mon Jan 05, 2009 3:56 pm

Publisher's Description


An Office Suite that runs from any portable memory device e.g. Thumb Drive, Memory Stick, Flash Drive etc. Will run on any netbook, laptop, and desktop computer instantly. BladeRunner is based on SSuite Advance Office for best hardware compatibility and system performance. Some utilities have been borrowed from the Fifth Element office suite.

This Office Suite is Portable in the following sense:
No installation of the software is required
It is a simple zip file => unzip, copy and paste to your thumb drive, memory stick, flash drive, or hard drive
Runs on Any and All Windows systems, from Windows 95 to Windows 7 - Build on pure WIN32 architecture
Leaves no residual files on the system or registry after closing
Uses relative drive paths for maximum portability of files
Completely compatible with other SSuite office suites that are already installed on your system

Operating Procedure:
Copy and paste all the files to the root folder of your portable memory device after being unzipped
Please read the "ReadMe.txt" file first before using the office suite
The unzipped file includes an "autorun.inf" for faster operation
Run all the applications and utilities from the start-up menu
Run the start-up menu first before using the applications and utilities.

IMPORTANT - Close the start-up menu last for best system performance. The start-up menu initializes and finalizes all the files for successful operation.

Minimum Requirements:
Runs on All Hardware and All Windows systems without any delay
Screen Size: 800x600
Portable Memory Device Size: 64MB
http://www.ssuitesoft.com/updates/ssuitemobile.zip
http://www.ssuitesoft.com/ssuiteportable.htm

User avatar
joby_toss
Posts: 2902
Joined: Sat Feb 09, 2008 9:57 am
Location: Romania
Contact:

#7 Post by joby_toss » Tue Jan 06, 2009 6:50 am

Strange stuff happened: error messages appeared when i tried to launch StartUpMenu.exe telling me that MFCANS32.DLL and oc30.dll were missing, but after I copied them from SSuiteMobile folder all went well.

carbonize
Posts: 363
Joined: Wed Jan 09, 2008 1:16 am
Location: Bristol, UK
Contact:

#8 Post by carbonize » Tue Jan 06, 2009 10:36 am

It does clearly mention that on it's site
Quick Fix - Error on Start Up

Problem Description:

* I am getting an error message that says there are files missing when I run "StartUpMenu.exe" in the portable office suite BladeRunner.

Fix:

* When you run the "StartUpMenu.exe" for the first time, you may get a message that the following dll's could not be found. { oc30.dll and MFCANS32.DLL }.
* They both can be found in the "SSuiteMobile" folder. Simply copy and paste them both to your system(Win 9x/ME) or system32 (XP/Vista/2000) folder. Everything else should work fine now.
* You can leave both files on your system. They will not do any harm.

yt22
Posts: 5
Joined: Fri Jan 09, 2009 5:23 am

#9 Post by yt22 » Fri Jan 09, 2009 5:30 am

The author of this software is quick to reply to my emails.

I am having problems running this bladerunner. When I run the startupmenu it runs fine but when I select wordgraph it gives me the "class not registered" popup. I try moving the two files to system32 before running startupmenu (i am running xp) and no luck. When I try to close the startupmenu via the 'X' it takes forever. I have to go to alt-cntr-del to close it.

I think I will wait to test this software until Andrew gives the go ahead to use.

User avatar
nickoftime
Posts: 52
Joined: Sat Dec 22, 2007 11:46 am
Location: USA

#10 Post by nickoftime » Fri Jan 09, 2009 2:29 pm

I have the same problem... all else works okay except WordGraph - same error as above. When it's corredcted, I'll try it again.

To the author: Is there any way you can keep the two dlls in the native directory, instead of copying it to a windows directory? This approach will make the package truly portable; I can keep it on my stick and run it on any PC.

Thanks, Nick

User avatar
joby_toss
Posts: 2902
Joined: Sat Feb 09, 2008 9:57 am
Location: Romania
Contact:

#11 Post by joby_toss » Fri Jan 09, 2009 11:29 pm

Forgot to say I did not copy those two files into the windows folder, but next to the launcher, so the package is really portable.

orchus
Posts: 22
Joined: Mon Aug 14, 2006 10:11 pm

#12 Post by orchus » Tue Jan 13, 2009 3:03 pm

I tried it Sandboxed, and it worked ok, as far as I tested it.
I did NOT print anything.
I copied the 2 DLLs (oc30.dll and MFCANS32.DLL) to the StartUpMenu.exe directory.

If you try to run it at various resolutions (other than required 800x600) it functions fine, but WordGraph, the word processor, has 2 "Floating Point Division by Zero" errors on opening a new document (at 640x480). But didn't seem to have any problems after the 2 errors. It spell-checks, word-counts, inserts tables, inserts images, inserts current date, Finds/Replaces, Undo/Redo, formats table/text/list, print-previews, shows help without any problems, for rtf, rtc, txt, doc, pas, cpp, h.

All other programs work fine, any resolution.

The Acel Spread-sheet did simple summations & formulas, print-previewed, sorted, changed formats, created chart, showed help for vts, xls, txt, csv.

The EZPhoto image editor could alter an image in simple ways, like add text, line-draw, brighten/darken, change contrast/colors, show help for jpg, bmp, wmf and can also save as (but not open) tiff and png.

The PDF memo creator can spell-check and seems largely intended as text only PDF-notepad, but bmp images can be inserted by clicking the little walking image on the toolbar or typing the word "TPicture" on lines where bmp should be inserted, and skipping enough lines for image insertion. It can open pdf and most of the formats as the word processor (rtf, txt, doc, pas, cpp, h) and saves as pdf, rtf, txt.

The Envelope Printer seems very easy to use to print one envelope address in any font, and can accept an address from the address book. It can print to envelope sizes: 11, 10, B5, DL-Maxi, DL, C5, C6, C65. It allows envelopes to be fed horizontally or vertically from right or left and shows an image of how the envelope is to be fed over a standard sheet of paper as well as showing where the address will print and the stamp should go. There's no mail-merge, help or detailed print-preview.

Search and Find, to locate files, seemed pretty quick, but doesn't have many features.

The MyWebBrowser is a skin for IE.
The Sorting Machine can sort a list, alphabetically or numerically.
The NoteBook is an unformated text only memopad.
The Windows Clipboard works with text only.
File Printer can print .prn files.
Tetris 2D has 9 levels and can be played using keyboard arrows.
The Email Viewer program started, and seemed ok, I didn't have a way to check it.

Over all the Envelope Printer (stand alone 1.2 Mb Envelopep.exe) and maybe the address book (1 Mb AddressBook.exe, 1Kb Address.dat) might be a good way for the uninitiated to quickly & easily print an envelope address or label (Note: does not print return addresses).

User avatar
Nh
Posts: 34
Joined: Tue Jan 22, 2008 5:01 am
Location: Georgia

#13 Post by Nh » Mon Jan 19, 2009 9:11 am

No unicode - big lack.

donald
Posts: 562
Joined: Wed Dec 19, 2007 4:14 am
Location: knoxville TN USA

Re: SSuite Office Portable v1.0

#14 Post by donald » Sat Nov 28, 2009 10:49 pm

Napiophelios wrote:I believe they have fixed the problem as it seems to work fine on my machine :D
This is a nice looking program.
The photo editor is the only feature that doesn't seem to work for me. :(
Unless Island boy wants to list this, it seems it is up for grabs, to list it.

GeddichNixan
Posts: 159
Joined: Fri May 09, 2008 6:03 am

Re: SSuite Office Portable v1.0

#15 Post by GeddichNixan » Sun Nov 29, 2009 2:47 pm

Quite some time ago I had tried an earlier version of this app, but then gave it up, it did not work for me. I do not remember the reason. As I saw it here, I thought why not give it another shot, so I tried it again.

First it informed me it could not create mfcans32.dll in my sytem32 folder. Than it informed me it could not create vfc132.dll in the same folder. I put both next to the launcher and the start menu showed up, but as I started WordGraph yet another error message appeared stating that a class was not registered. That was the point as I finally gave it up and deleted the app from my computer. Beside this the program created a number of ocx and dll files of 0 size in my system32 folder (I ran the app in a Sandbox at that time). The strangest of all this was that the firs missing file mfcans32.dll HAD ALREADY BEEN in the required system32 folder at the first start.

I am truly not a computer expert, so my criticism is probably wrong. Nevertheless I really would like to know how can anybody call a software like this portable. First I need to modify my system a way it likes and then it is (probably) willing to work fine. It puts files into my system32 folder or askes me to do so. It starts with "put these to files from a subfolder next to the launcher" instead of having them already where they have to be. Beg your pardon?

A portable software in my understanding is (which may differ from others') one of the "unpack-it-click-the-exe-and-it-works" type. This one here is something like unpack-it-click-the-exe-it-wont-work-so-put-some-files-somewhere-and-register-some-dlls-and-do-some-other-theses-and-thats.... kind.

My impression is, that it is not (yet) a portable application but a zipped package of an otherwise installed software and one has to do some modifcation of the system what otherwise the installer would do. I don't know how it works on other systems than mine (XP SP3), but in its current state it is an absolute no go for me.

Post Reply