ASuite - application launcher

Submit portable freeware that you find here. It helps if you include information like description, extraction instruction, Unicode support, whether it writes to the registry, and so on.
Message
Author
Darkbee
Posts: 291
Joined: Mon Feb 06, 2006 8:35 am
Contact:

#46 Post by Darkbee » Sat Jan 20, 2007 2:35 pm

As I suspected, I've been checking again and PStart memory usage seems to peak at around 9MB (which is a figure that I had in my head from previous tests). So, ASuite isn't too far behind, I'm just a minimalist kinda guy... basically I'm tight fisted and refuse to shell out for a 10GHz quad core PC with nuclear fusion plant strength cooling capability... if all I have to do is walk 100 metres what's the point in having a Ferrari to get there?

@Fluffy *bittorrent of abuse* ... :twisted: sersiously, your comment about a rating system struck a chord with me because I've long held the view that the "comments" are pretty much pointless. People use them to bitch and complain about how they can't get this to work, or they can't find this feature, or program x is better at doing action y etc. etc.

However, I would also caution against a simple 5 star rating system too because that doesn't really tell you much either, for example suppose that an application is super efficient at what it does but it has a user interface from the bowels of hell, how do you rate the app? Anyway, I digress, perhaps this is one for another topic. I don't want to distract from El Salvador's excellent work.

User avatar
Fluffy
Posts: 459
Joined: Sat Apr 15, 2006 6:37 pm

#47 Post by Fluffy » Sat Jan 20, 2007 3:15 pm

Darkbee: Screw your damn cars. :P

El Salvador: I have encountered a show-stopper bug with ASuite. When playing a video with KMPlayer while ASuite is running, I cannot get video to show up in fullscreen. As soon as I kill ASuite and restart KMPlayer, the problem disappears. This only occurs when the mouse sensors are active. I use these mouse sensors with PStart and the problem does not occur. Any ideas?

Also, why are the number keys and spacebar not bindable? Is there a way to make the hotkey to show ASuite simply bring up the menu instead of spawn the window?
How much Keefe is in this movie? Miles O' Keefe!

User avatar
Andrew Lee
Posts: 2467
Joined: Sat Feb 04, 2006 9:19 am
Contact:

#48 Post by Andrew Lee » Sun Jan 21, 2007 3:43 am

Started a new topic in Chit-Chat about a rating system for TPFC.

If you have time, please head on over to discuss!

El Salvador
Posts: 69
Joined: Sun Feb 26, 2006 11:35 am

#49 Post by El Salvador » Sun Jan 21, 2007 9:04 am

Hello everybody. :D
The memory usage seems to be more than double that of PStart. For 111 items (I imported them directly from the PStart.xml file) ASuite's memory usage was around 14MB whereas PStart was at around 6MB. Asuite's executable may be "Lightweight: only 460KB" but is there any chance of bringing the memory usage down a bit?
"Lightweight: only 460KB" is executable's size. :)

I test ASuite 1.4 (wip) and PStart 2.08 with a little list (35 software, 20 category) and I get memory usage in startup time:

ASuite (with cache) 6.9MB
ASuite (without cache) 9.7MB
PStart 8.5MB

In effect, PStart uses less memory usage than ASuite and I don't know how it is possible. Maybe PStart uses different system to load/manage resource internally. :)
I would say that if ASuite's memory usage was on par with PStart then it would become a serious contender to replace the mighty PStart... give yourself a pat on the back El Salvador for a job well done... so far!
Thank you. :D
Wow, I just checked out ASuite (for the most part I was happy with PStart and didn't really bother checking it out) and I must say that it's a fantastic piece of software. I really like it a lot, good job!
[...]
I'm definitely switching over to this from PStart. The layout is far superior and it "feels" nicer.
Thank you. :D
However, can you make it so the windows key is bindable for hotkeys?
I will add windows key (and numbers) in ASuite 1.5.
Also, while dragging items the list does not scroll up or down, can this be implemented as well?
Yes, I just added it in ASuite 1.4. :wink:
A nifty little idea to munch on: integration with TPFC. You'd hafta talk it over with Andrew to see how it'd all work out, but when you click "Retrieve Information" you could have it optionally query TPFC to fill out Description and Home Page as well as check out Version information and optionally inform the user of available updates. If we ever get a rating system set up here the Rating could also be gathered from TPFC. Could be very interesting to look into, at least. Smile
It is interest idea to retrieve desc, home page and ratings (of course if you get a rating system) from TPFC and I hope it is possible.

I have already thought on an update system for list's software, but I don't have time to manage software updates on a website.
Bug problem: I can't seem to get Home Pages to open. I click on the Home Page link, but nothing comes up with Opera.
I just tried and it works with IE7 (it is default browser, but I uses Firefox :roll: ). Tonight I will test with Firefox and Opera.
Is there a way to make the hotkey to show ASuite simply bring up the menu instead of spawn the window?
For now, no. I will add it in ASuite 1.5.
I have encountered a show-stopper bug with ASuite. When playing a video with KMPlayer while ASuite is running, I cannot get video to show up in fullscreen. As soon as I kill ASuite and restart KMPlayer, the problem disappears. This only occurs when the mouse sensors are active. I use these mouse sensors with PStart and the problem does not occur. Any ideas?
Tonight I will test it. Thank you.

El Salvador
Posts: 69
Joined: Sun Feb 26, 2006 11:35 am

#50 Post by El Salvador » Thu Feb 15, 2007 6:22 am

Yesterday I released ASuite 1.4 Beta. If you want to try it: http://sourceforge.net/project/showfile ... _id=171280

Anyway, today I fix this small bug:
Bug problem: I can't seem to get Home Pages to open. I click on the Home Page link, but nothing comes up with Opera.
I have encountered a show-stopper bug with ASuite. When playing a video with KMPlayer while ASuite is running, I cannot get video to show up in fullscreen. As soon as I kill ASuite and restart KMPlayer, the problem disappears. This only occurs when the mouse sensors are active. I use these mouse sensors with PStart and the problem does not occur. Any ideas?
And I tried it and you are right, but I didn't fix it. I changed a function's code (cause) to change alpha of sensors (they are forms with alpha at 1), but nothing.

El Salvador
Posts: 69
Joined: Sun Feb 26, 2006 11:35 am

ASuite 1.4 stable version released

#51 Post by El Salvador » Fri Mar 16, 2007 3:46 pm

ASuite 1.4! http://sourceforge.net/projects/asuite/ :D

Thank you everybody :wink:

El Salvador
Posts: 69
Joined: Sun Feb 26, 2006 11:35 am

#52 Post by El Salvador » Tue Aug 21, 2007 12:15 pm

News
From June, I couldn't work on ASuite 1.5 and in general, ASuite 1.5's development is very slow (and so on I will release new version December or later) for 2 reasons:
1 I'm only: I developed, I tested beta version and etc... I have feedback from you and some users (better than nothing, but ASuite isn't famous and hasn't a community as PStart or PAM...), but I can't work all alone.
2 I haven't much free time.

Therefore I'm looking for people (form designers, delphi developers, testers and etc...) to help me: I want to make a team to work on asuite's future version.

XPect
Posts: 36
Joined: Tue Feb 07, 2006 4:38 am
Location: France

#53 Post by XPect » Wed Aug 22, 2007 6:29 am

Hi El Salvador,

Can't help on development, I have no time for this but can help on testing. Just let me know how I can help.

Regards

El Salvador
Posts: 69
Joined: Sun Feb 26, 2006 11:35 am

#54 Post by El Salvador » Wed Aug 22, 2007 2:09 pm

Thank you xpect for your helpl.

Next week or later, I will release first alpha of ASuite 1.5 for you. You can wait this version or if usually use ASuite 1.4 you can test this version. Your own choice. Smiling

P.S.: I don't need testers anymore (but if find bugs, send me bug report). I need at least one delphi developers yet.

USB_Kx
Posts: 92
Joined: Sun Aug 05, 2007 2:58 pm

#55 Post by USB_Kx » Thu Aug 23, 2007 12:54 am

Hi. Im no developer but for what it's worth. I love your software.

Regards.

El Salvador
Posts: 69
Joined: Sun Feb 26, 2006 11:35 am

#56 Post by El Salvador » Mon Sep 17, 2007 2:27 pm

@XPect and other testers: Last week, I released ASuite 1.5 Alpha 1. It is a untested (and so unstable) version and it is being made available for testing purposes only.

More info on this topic http://portableapps.com/node/9132

User avatar
Gary
Posts: 43
Joined: Mon May 15, 2006 5:13 am

#57 Post by Gary » Mon Sep 17, 2007 7:49 pm

Excellent software, El Salvador!
...untested (and so unstable)...
Hmm... I tested and unstable. Should I be concerned???!!!


--Gary ;-)

XPect
Posts: 36
Joined: Tue Feb 07, 2006 4:38 am
Location: France

#58 Post by XPect » Tue Sep 18, 2007 7:46 am

Hello El Salvador

1st quick test, no stability problem for me.

Still have a problem with the windows on top option, when checked if you choose option from the Asuite windows, the option windows is showed under the Asuite window.
I've lost the backgroud in tha A suite window, not a problem to reselect it, but don't know if this come from the upgrade or not.
I've lost the the cursor personalisation option when you place the mouse on the screen border.

regarding changelog:
Added
- Load another list through asuite's exe parameter (work fine)
- Parameters and working directory in desktop's shortcut (work fine but could you had the icon parameter too)
- Automatic opening/closing of categories (don't understand this)
- Support environment variables (seem ok, but not all environment variable tested yet)

Various
- Rewrited component to download file and Update System (not tested)
- Sort list: categoris will to position prior to software (work fine)
- New icon for category (ok)
- Updated lang: French, Portuguese, Spanish, Turkish (ok for French)
- Added lang: Danish (not tested lol)

Toxteth O'Grady
Posts: 172
Joined: Wed Feb 15, 2006 12:06 am

#59 Post by Toxteth O'Grady » Wed Sep 19, 2007 12:23 am

Hello El Salvador

The new, beta verson looks very good. I think the new options are great (I really like "Load another list through asuite's exe parameter").
it's good enough for me, even if it is "unstable". :wink:

Just take your time with development if nobody can help you. There is no rush.

Keep up the good work. :D

XPect
Posts: 36
Joined: Tue Feb 07, 2006 4:38 am
Location: France

#60 Post by XPect » Wed Sep 19, 2007 2:18 am

After a few try, it seem that the button used to retrieve informations from the exe works in less cases than before, but this is very subjective.

Regards

Post Reply