Page 3 of 4

Re: gaP: great! another Portabilizer

Posted: Tue Jan 30, 2018 1:21 am
by Stibbert
I'm trying to move a file (a communication driver) from Settings\System32 to Windows\System32

file = %Windows%\System32\lpcapapi.dll :: Settings\System32\lpcapapi.dll

What I obtain is a new folder in MyApp with the name %Windows%...

What is wrong? Thanks

Re: gaP: great! another Portabilizer

Posted: Tue Jan 30, 2018 1:51 am
by Stibbert
I've found the error: %Windir%

Re: gaP: great! another Portabilizer

Posted: Thu Feb 01, 2018 11:20 am
by Stibbert
I have to write a line in registry in this type:

@="\"C:\\Program Files (x86)\\MyApp\\MyApp.exe\" \"%1\""

There are some single quote and double quote.
GAP add a " every time find single quote...
How can avoid this?

IS POSSIBLE???

Thanks

Re: gaP: great! another Portabilizer

Posted: Thu Feb 01, 2018 11:28 am
by Stibbert
Sorry.

I've make a mistake...

The symbol is backslash \

Re: gaP: great! another Portabilizer

Posted: Mon Feb 19, 2018 1:00 am
by Stibbert
GAP is still supported or it is an abandonware?

Re: gaP: great! another Portabilizer

Posted: Fri Feb 23, 2018 8:53 am
by Stibbert
I don't understand...

I have a folder in AppData/Local.
I have written:

dir = %AppData%\Local\MyFolder :: Settings/MyFolder
dir = %AppData%\MyFolder :: Settings/MyFolder

Not in the same app, in two different test, but nothing happen...

If MyFolder was in Appdata/Local wasn't copied to Settings.
If is in Settings, is not copied in AppData/Local.

Other times (other appplications) everythings goes well.

What is wrong?

Thanks

Re: gaP: great! another Portabilizer

Posted: Sat Feb 24, 2018 5:03 am
by Midas
I may be wrong here, but the first case (line) looks malformed to me -- i.e., the 'Local' segment is usually implicit...

You could try it with yaP...

Re: gaP: great! another Portabilizer

Posted: Sun Feb 25, 2018 2:34 am
by Stibbert
Thanks.

But GAP and YAP Shouldn't have the same syntax?

(I know and I'm sure AppData/Roaming is implicit).

Re: gaP: great! another Portabilizer

Posted: Sun Feb 25, 2018 4:50 am
by Midas
Sorry, I wouldn't know, I haven't done any significant use of gaP...

Re: gaP: great! another Portabilizer

Posted: Thu Mar 01, 2018 9:06 am
by Stibbert
Good morning.

I've written:

!admin = 1
file = %Windir%\System32 :: Settings/System32/Mylibrary.dll

The goal is move a file from Settings/System32 to Windows/System32 but the code don't work...
Why?

Thanks

Re: gaP: great! another Portabilizer

Posted: Thu Mar 01, 2018 9:54 am
by SYSTEM
Stibbert wrote:
Thu Mar 01, 2018 9:06 am
Good morning.

I've written:

!admin = 1
file = %Windir%\System32 :: Settings/System32/Mylibrary.dll

The goal is move a file from Settings/System32 to Windows/System32 but the code don't work...
Why?

Thanks
My guess: gaP is a 32-bit program, and when it tries to access System32, it gets redirected to SysWOW64.

To work around it, try

Code: Select all

!admin = 1
file = %WinDir%\Sysnative :: Settings/System32/Mylibrary.dll

Re: gaP: great! another Portabilizer

Posted: Thu Mar 01, 2018 10:17 am
by Stibbert
Don't work! :cry:

The portabilizer create in the main folder (of portabilizer, between App and settings) a folder named %Windows%.

I don'understand...

Re: gaP: great! another Portabilizer

Posted: Thu Mar 01, 2018 10:23 am
by Stibbert
And the same behaviour is if I use SysWOW64!

Re: gaP: great! another Portabilizer

Posted: Thu Mar 01, 2018 10:52 am
by SYSTEM
Stibbert wrote:
Thu Mar 01, 2018 10:17 am
Don't work! :cry:

The portabilizer create in the main folder (of portabilizer, between App and settings) a folder named %Windows%.

I don'understand...
If it's creating a folder named %Windows%, chances are that you wrote %Windows% in the configuration file. It's supposed to be %WinDir% or its newer alternative, %SystemRoot%.

Re: gaP: great! another Portabilizer

Posted: Thu Mar 01, 2018 11:39 am
by Stibbert
!chances are that you wrote %Windows% in the configuration file"

Maybe...

I've made many tests to obtain what I was looking for.

(I've tryed GAP and YAP too).

Finaly:

With sysnative, GAP copy the dll to S32, but when closing, the dll remain in windows.

I've a question for you. GAP, after changed icons works again? I've tryed with many computer, but ALWAYS, after icon modified, GAP fail to work!