Drag and drop not functioning

If you are currently developing portable freeware or planning to do so, use this forum to discuss technical implementation, seek out like-minded developers for partnership, or solicit interested users for beta testing.
Post Reply
Message
Author
cxp4
Posts: 2
Joined: Sat Jul 12, 2014 11:24 am

Drag and drop not functioning

#1 Post by cxp4 » Sat Jul 12, 2014 11:31 am

Instead of the expected action I get a sound and nothing else happens, not even an error message.
Running on windows 64 8.1

Any idea?

Thanks

User avatar
joby_toss
Posts: 2902
Joined: Sat Feb 09, 2008 9:57 am
Location: Romania
Contact:

Re: Drag and drop not functioning

#2 Post by joby_toss » Sun Jul 13, 2014 3:17 am

It's working fine for me.

freakazoid
Posts: 1039
Joined: Wed Jul 18, 2007 5:45 pm

Re: Drag and drop not functioning

#3 Post by freakazoid » Sun Jul 13, 2014 1:41 pm

Are you using Windows Explorer? Then that's probably the reason.

You need to give elevated rights to Explorer or use an alternative file manager and use elevated rights. The easiest way to provision elevated rights is to right-click on the file manager's .exe and click on "Run as administrator".

FYI, I use this command-line program app:
http://code.kliu.org/misc/elevate/

To elevate XYPlorer programatically.
is it stealth? ;)

User avatar
tproli
Posts: 1172
Joined: Sat Sep 09, 2006 10:14 am
Location: Hungary
Contact:

Re: Drag and drop not functioning

#4 Post by tproli » Sun Jul 13, 2014 10:18 pm

I still miss the info that where DnD does not work.

User avatar
joby_toss
Posts: 2902
Joined: Sat Feb 09, 2008 9:57 am
Location: Romania
Contact:

Re: Drag and drop not functioning

#5 Post by joby_toss » Mon Jul 14, 2014 4:45 am

You too? But no problem, it's the Portable Freeware Development section. :)

User avatar
Midas
Posts: 5534
Joined: Mon Dec 07, 2009 7:09 am
Location: Sol3

Re: Drag and drop not functioning

#6 Post by Midas » Mon Jul 14, 2014 6:11 am

Do you mean... it'll develop? Like a Polaroid? :twisted:

User avatar
tproli
Posts: 1172
Joined: Sat Sep 09, 2006 10:14 am
Location: Hungary
Contact:

Re: Drag and drop not functioning

#7 Post by tproli » Mon Jul 14, 2014 6:57 am

Instead of the expected action I get a sound and nothing else happens, not even an error message
That's sooo... stealth!

cxp4
Posts: 2
Joined: Sat Jul 12, 2014 11:24 am

Re: Drag and drop not functioning

#8 Post by cxp4 » Thu Jul 17, 2014 1:49 pm

freakazoid wrote:Are you using Windows Explorer? Then that's probably the reason.

You need to give elevated rights to Explorer or use an alternative file manager and use elevated rights. The easiest way to provision elevated rights is to right-click on the file manager's .exe and click on "Run as administrator".

FYI, I use this command-line program app:
http://code.kliu.org/misc/elevate/

To elevate XYPlorer programatically.
Thanks for your recommendation. Drag and drop works with XYplorer in elevated mode.

Post Reply