TPFC migration

Changes, updates etc. related to this website will be posted here.
Message
Author
User avatar
__philippe
Posts: 504
Joined: Wed Jun 26, 2013 2:09 am

Re: TPFC migration

#31 Post by __philippe » Sun Jan 07, 2018 5:17 am

Andrew Lee wrote:
Sun Jan 07, 2018 3:58 am
... I have installed ProSilver SE and Revolution for you guys to test out. ...
Tried them all available fancy styles, gladly stick with the current default "AllanStyle-SUBSILVER", thanks for asking...;-)
(As suggested earlier by Midas, the "online user ribbon" might perhaps look better relocated back on the left-hand side ?)

User avatar
Midas
Posts: 4378
Joined: Mon Dec 07, 2009 7:09 am
Location: Sol3

Re: TPFC migration

#32 Post by Midas » Sun Jan 07, 2018 5:36 am

Well, I tried the new options, too. Revolution is truncating the TPFC forum logo and we sure can't have that...

OTOH, ProSilver Special Edition is looking fine thank you -- although it takes some getting used to those ominous dark gray box headers. Light blue is so much more convivial. ;)

For me, the best thing about these styles is how they narrow the page width, enhancing readibility.

Image

Image

Specular
Posts: 311
Joined: Sun Feb 16, 2014 10:54 pm

Re: TPFC migration

#33 Post by Specular » Sun Jan 07, 2018 7:33 am

Andrew Lee wrote:
Sun Jan 07, 2018 3:53 am
Still happening for you? I switched to using this extension in preparation for supporting multiple board styles. Apparently, I think the logo is dynamically updated using Javascript. It's working for me on both Firefox and Chrome.
Ah, that was it. I use a script manager addon and the forum's Javascript wasn't enabled. All good now, though using Javascript for a static logo seems a little overkill 😛.

As for the user 'online' strip it's actually an image. So either a CSS rotation transform or replacement image could be used to bring it over to the other side. I'll look at it tomorrow perhaps.

billon
Posts: 598
Joined: Sat Jun 23, 2012 4:28 pm

Re: TPFC migration

#34 Post by billon » Sun Jan 07, 2018 9:57 am

@Andrew Lee:

Something go wrong and now "smileys" are shown instead of some characters in the entries (and possible in the comments?)
For example, see MobaXterm entry:

Ss_2018-01-07_20-51-09.png
That break all functionality, please fix it ASAP
Completely turn off "smileys" in the main site
Image

billon
Posts: 598
Joined: Sat Jun 23, 2012 4:28 pm

Re: TPFC migration

#35 Post by billon » Sun Jan 07, 2018 10:14 am

Also as we can see, there is no such "smiley" (:\) in the forum's "Full Editor & Preview" form:

Ss_2018-01-07_21-11-03.png
Ss_2018-01-07_21-11-03.png (3.55 KiB) Viewed 4547 times
So there are different "smileys" in the forum and in the main site
Now I think that migration to the new engine was not so good idea
Image

User avatar
Andrew Lee
Posts: 2228
Joined: Sat Feb 04, 2006 9:19 am
Contact:

Re: TPFC migration

#36 Post by Andrew Lee » Sun Jan 07, 2018 1:04 pm

billon wrote:
Sun Jan 07, 2018 9:57 am
That break all functionality, please fix it ASAP
Completely turn off "smileys" in the main site
Fixed. Thanks for reporting this!

billon
Posts: 598
Joined: Sat Jun 23, 2012 4:28 pm

Re: TPFC migration

#37 Post by billon » Sun Jan 07, 2018 2:28 pm

Andrew Lee wrote:
Sun Jan 07, 2018 1:04 pm
Fixed.
No
There now spaces, spaces everywhere, in every entry, in additional fields such as Dependencies:, License:, How to extract:, Similar/alternative apps: etc
Even worser then with those damn smilies
Something is broken with the main site
Attachments
Ss_2018-01-08_01-16-54.png
Image

User avatar
JohnTHaller
Posts: 618
Joined: Wed Feb 10, 2010 4:44 pm
Location: New York, NY
Contact:

Re: TPFC migration

#38 Post by JohnTHaller » Sun Jan 07, 2018 3:45 pm

billon wrote:
Sun Jan 07, 2018 2:28 pm
No
There now spaces, spaces everywhere, in every entry, in additional fields such as Dependencies:, License:, How to extract:, Similar/alternative apps: etc
Even worser then with those damn smilies
Something is broken with the main site
I think JUSTIFY is set as the alignment for those fields in CSS.
PortableApps.com - The open standard for portable software | Support Net Neutrality

User avatar
Andrew Lee
Posts: 2228
Joined: Sat Feb 04, 2006 9:19 am
Contact:

Re: TPFC migration

#39 Post by Andrew Lee » Mon Jan 08, 2018 2:45 am

billon wrote:
Sun Jan 07, 2018 2:28 pm
No
There now spaces, spaces everywhere, in every entry, in additional fields such as Dependencies:, License:, How to extract:, Similar/alternative apps: etc
Even worser then with those damn smilies
Something is broken with the main site
How about now?

billon
Posts: 598
Joined: Sat Jun 23, 2012 4:28 pm

Re: TPFC migration

#40 Post by billon » Mon Jan 08, 2018 11:36 am

Thank you, everything looks correct now :)

I hope :shock:
Image

billon
Posts: 598
Joined: Sat Jun 23, 2012 4:28 pm

Re: TPFC migration

#41 Post by billon » Mon Jan 08, 2018 11:42 am

Sometimes (not always, randomly), when you login from the site, you redirected to this error page:
Ss_2018-01-08_21-59-57.png

You actually logined successfully, just didn't redirected to the previous page, but to this error page
Image

billon
Posts: 598
Joined: Sat Jun 23, 2012 4:28 pm

Re: TPFC migration

#42 Post by billon » Mon Jan 08, 2018 11:32 pm

And now TPFC certificate is expired and Firefox won't let me in! :shock:
WTF is happen?
That migration was surely bad idea

And search don't work! :evil:
Image

olliebean
Posts: 13
Joined: Sun Mar 20, 2011 2:44 am

Re: TPFC migration

#43 Post by olliebean » Tue Jan 09, 2018 4:49 am

Confirmed, the certificate shows as expired this morning. Edge gives me the option to proceed to the site anyway, but Firefox doesn't.

Also confirmed, search isn't working. And in general the site is loading slower than I would expect.

User avatar
Andrew Lee
Posts: 2228
Joined: Sat Feb 04, 2006 9:19 am
Contact:

Re: TPFC migration

#44 Post by Andrew Lee » Tue Jan 09, 2018 1:26 pm

The cert renewal process with Let's Encrypt was botched, so that has been fixed now.

Serarch is also working fine as far as I can tell. Anyone else hitting problems?

User avatar
Andrew Lee
Posts: 2228
Joined: Sat Feb 04, 2006 9:19 am
Contact:

Re: TPFC migration

#45 Post by Andrew Lee » Tue Jan 09, 2018 1:30 pm

billon wrote:
Mon Jan 08, 2018 11:42 am
Sometimes (not always, randomly), when you login from the site, you redirected to this error page:

You actually logined successfully, just didn't redirected to the previous page, but to this error page
If it's random, it'll be hard to diagnose until we have more info. I just tried with Firefox and Chrome. Steps I took:

1. Logout from TPFC
2. Pop into any random database entry page.
3. Click "Login" from top of page.
4. After login, I'm redirected back the same database entry page in (2)

If you guys hit this problem again, try to note the exact sequence of steps you took and post them here.

Post Reply