No more updates on the front page?

All suggestions about TPFC should be posted here. Discussions about changes to TPFC will also be carried out here.
Post Reply
Message
Author
billon
Posts: 554
Joined: Sat Jun 23, 2012 4:28 pm

No more updates on the front page?

#1 Post by billon » Thu Apr 13, 2017 5:09 am

@Andrew Lee:

For two(?) days, updates are not shows in "Recent Forum Posts", "Recent Comments" and "Recent Updates" on the right side of front page.
In "Recent Forum Posts" last is "Setup with Truecrypt and VMware", in "Recent Comments" is by Mixture for "TheSage" and in "Recent Updates" - "HTTPNetworkSniffer" from 10 Apr.
As you can see, there was newer forum posts, updated programs and entries' comments (not sure about last - how did you know, if there are new comments, if they just not updated? But my test comments not displayed on fist page for sure).
What happened?

User avatar
webfork
Posts: 7693
Joined: Wed Apr 11, 2007 8:06 pm
Location: US, Texas
Contact:

Re: No more updates on the front page?

#2 Post by webfork » Thu Apr 13, 2017 2:50 pm

What happened?
You're not alone on this. I've contacted Andrew about it.
Supporting Net Neutrality - BattleForTheNet | Why this matters | More from EFF.org

billon
Posts: 554
Joined: Sat Jun 23, 2012 4:28 pm

Re: No more updates on the front page?

#3 Post by billon » Mon Apr 17, 2017 1:35 pm

This happening again? :evil:

__philippe
Posts: 470
Joined: Wed Jun 26, 2013 2:09 am

Re: No more updates on the front page?

#4 Post by __philippe » Tue Apr 18, 2017 5:58 am

Yep, noticed that too... :roll:

Front page right-column "Recent Posts | Comments | Updates" highlights stopped appearing between 17-APR-2107 (from about 13:00 CET)
until 18-APR-2017 (about righ now 14:50), when a slew of update highlights did eventually turn up again.

Looks like recurring hiccups, of late...?

User avatar
Andrew Lee
Posts: 2208
Joined: Sat Feb 04, 2006 9:19 am
Contact:

Re: No more updates on the front page?

#5 Post by Andrew Lee » Wed Apr 19, 2017 5:41 am

As I explained to webfork, this is related to the check I added recently to prevent two instances of the maintenance job from running at the same time.

The two day of MIA was first brought to my attention by webfork via a PM, so I added some extra debug statements to the script, and started monitoring the situation on a daily basis.

The second MIA ("17-APR-2107 (from about 13:00 CET) until 18-APR-2017 (about righ now 14:50)") was spotted more quickly during the daily check and quickly rectified. More debug statements were added to hopefully help in nailing down the issue.

That's where we're at so far...

billon
Posts: 554
Joined: Sat Jun 23, 2012 4:28 pm

Re: No more updates on the front page?

#6 Post by billon » Tue May 16, 2017 10:35 am

again

User avatar
Andrew Lee
Posts: 2208
Joined: Sat Feb 04, 2006 9:19 am
Contact:

Re: No more updates on the front page?

#7 Post by Andrew Lee » Thu May 18, 2017 3:33 am

Noticed and remedied. I check this daily now, so any problems are caught sooner.

I think I have a clue of what's causing this intermittent problem. I'm still thinking of a way to fix it...

Post Reply